Is this a brick?


New Member
Jan 12, 2022
Recently I bought a new (to me) truck that came with this camera set. The previous owner had it installed less than a year ago and said it wasn't working with the rear camera. He was told to update the firmware and, being a Luddite of sorts, gave up trying. I checked the install which was properly done and proceeded to try the update. I installed on a 128 card and followed all procedures to no avail. If I plug in the camera to power I get the camera on with the wifi symbol plastered across it, the record and mic lights solid red. All buttons except on and off do nothing. If I plug it into the computer I get the blue screen with Micro SD reader mode. All buttons do nothing in this mode. The is no DCIM folder on the card but I assume it's created with the update. (I have tried it both ways and also tried a smaller different card. What I do not have is the original cables but have tried two different short cables. The camera will boot up with or without power and with or without SD card. I think the internal batteries were run right down so I left it on charge for several hours. So... pretty well done all I can do and the next step may be to remove it all and toss it. I don't want to do this but am not paying for another front camera at $300+ Can. Input would be muchly appreciated.